This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
The Smartsheet and Brandfolder add-ons for Google Docs, Sheets, and Slides were unavailable due to a Google platform change that required all affected add-ons to be redeployed. Our team has applied the necessary fixes and we are currently monitoring to confirm full stability.
Posted Jun 10, 2026 - 20:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2026 - 17:51 PDT
Investigating
We are investigating the Smartsheet add-ons for Google which is currently not available. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.