This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Starting at 3:30 PM PT on July 9, 2025, unusually high service load began causing intermittent delays in users being able to access newly created assets (sheets, reports, dashboards, forms). While the assets were still created, users may have seen permission errors when initially trying to view them. The high load source was identified and, once cleared, the service began recovering with access fully restored by 4:21 PM PT.
Posted Jul 09, 2025 - 20:23 PDT
Resolved
This incident has been resolved.
Posted Jul 09, 2025 - 18:27 PDT
Monitoring
A fix has been implemented, we are monitoring the results.
Posted Jul 09, 2025 - 16:29 PDT
Investigating
We are currently investigating an issue where users may encounter an "Access Denied" error after creating assets such as sheets, reports, dashboards, or workspaces. While the assets are being created successfully, this error may appear temporarily when attempting to access them.
Refreshing the page or waiting a few minutes typically resolves the issue.
We are working to resolve this behavior and will provide updates as more information becomes available.
Posted Jul 09, 2025 - 16:09 PDT
This incident affected: Core Application (Sheets, Forms, Reports, Dashboards).