This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 10:19 PST
Update
This issue has been identified and a fix has been implemented for new form submissions. For previous form submissions that failed in this window, a manual replay will be ran. Please do not re-submit these form submissions.
Posted Mar 03, 2026 - 09:52 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 03, 2026 - 09:47 PST
Investigating
We've investigating an issue with Form Submissions propagating to the sheet. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.