This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2026 - 09:22 PDT
Identified
We have implemented a fix to mitigate the issue causing sheets in the US Smartsheet instance to fail to load, as well as the impact on Reports, Dashboards, and Premium Apps (Dynamic View, WorkApps, Resource Management, and Control Center). System metrics are currently showing recovery, and our team is actively monitoring the service to ensure full stability. We will post further updates until the incident is fully resolved.
Posted Aug 26, 2026 - 09:08 PDT
Update
We are continuing to investigate this issue.
Posted Aug 26, 2026 - 08:47 PDT
Update
We're still investigating an issue where some sheets in the US Smartsheet instance are failing to load. This issue is also impacting Reports and Dashboards, as well as Premium Apps including Dynamic View, WorkApps, and Resource Management. Our team remains fully engaged in addressing the situation. We will continue to provide frequent updates until we reach a monitoring status.
Posted Aug 26, 2026 - 08:17 PDT
Update
We're still investigating an issue where some sheets in the US Smartsheet instance are failing to load. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.
Posted Aug 26, 2026 - 07:39 PDT
Investigating
We're investigating an issue where some sheets in the US Smartsheet instance are failing to load. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.
Posted Aug 26, 2026 - 06:28 PDT
This incident affected: Resource Management (Resource Management), Advance Capabilities (Control Center, Dynamic View, WorkApps), AI Tools, and Core Application (Sheets, Reports, Dashboards).