Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Investigating Workflow Automation and Search delays and errors loading Sheets

Incident Report for Smartsheet

Postmortem

Due to some timeout issues some customers were seeing delays in automated workflows starting at 11:26 GMT. The root cause was determined and resolved by additional cpu resources.

Posted Mar 27, 2025 - 11:07 PDT

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 11:03 PDT

Monitoring

A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Mar 27, 2025 - 08:38 PDT

Identified

We have identified the issue and taken action to resolve. The service is recovering and we will continue to monitor. We will continue to provide frequent updates as we work towards resolution.
Posted Mar 27, 2025 - 08:18 PDT

Investigating

We are currently investigating some customer reports of Workflow Automation delays and errors loading Sheets. We will continue to provide frequent updates as we work towards resolution.
Posted Mar 27, 2025 - 07:57 PDT
This incident affected: Workflows (In App Workflows), Core Application (Sheets), and Search.