Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Google Cloud Service Incident affecting Smartsheet Functionality

Incident Report for Smartsheet

Postmortem

On June 12th, 2025, starting at approximately 10:50 AM PDT, we observed a spike in errors and increased latency across several of our core services. Our immediate investigation revealed that the issues were stemming from a service outage experienced by Google Cloud, one of our infrastructure providers. All affected services were fully restored by 1:40 PM PDT on the same day, following Google Cloud's resolution of their incident.

Posted Jun 13, 2025 - 08:13 PDT

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 16:21 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 14:18 PDT

Update

Google Cloud's incident is resolving, and we're seeing our capabilities recover. Brandfolder is currently processing its queue of uploads.
Posted Jun 12, 2025 - 14:06 PDT

Update

Google Cloud's incident is resolving, and we're seeing our capabilities recover. Brandfolder is currently processing its queue of uploads.
Posted Jun 12, 2025 - 14:04 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 13:11 PDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 13:02 PDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 12:08 PDT

Investigating

Smartsheet customers may encounter errors when attempting to upload, download, or process files using Brandfolder and File Library. Other Google-integrated features, including reCAPTCHA for login and Google Drive uploads, might also experience increased latency or error rates. Our operations team is actively monitoring the situation. We apologize for the inconvenience.

https://status.cloud.google.com/
Posted Jun 12, 2025 - 11:54 PDT
This incident affected: Documents (Attachments, File Library), Digital Asset Management (Brandfolder) (Smartsheet Brandfolder Integration, Core Application, Asset Upload, Asset Upload - SFTP, SmartCDN, Brandguide, Integrations, Insights, Content Automation Platform, Content Automation APIs, Content Automation Rendering Services, Content Automation Templating, Content Automation Integrations), Workflows (Bridge by Smartsheet), and Third Party Sign In (Sign in via Google).