This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
We are observing stability being restored for the User & Group Management pages in Admin Center. A page refresh or clearing of cache from this page from your browser might be necessary for full resolution. We are continuing to monitor it closely to confirm full service stability.
Posted Mar 24, 2026 - 09:08 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 24, 2026 - 09:07 PDT
Investigating
We are investigating blank results showing on User & Group Management pages in Admin Center. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.
Posted Mar 24, 2026 - 08:16 PDT
This incident affected: Administration and Audit (User and Group Management).