This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
We experienced workflow processing delays starting at 10:23 AM ET due to a system issue. Our team took corrective actions, and by 12:04 PM ET, workflows were running normally again. All systems are now fully operational.
Posted Mar 25, 2025 - 07:29 PDT
Resolved
This incident has been resolved.
Posted Mar 20, 2025 - 08:56 PDT
Investigating
We have identified an issue causing automated workflows to be delayed and some sheets not opening and we are taking action to resolve.
Posted Mar 20, 2025 - 07:55 PDT
This incident affected: Workflows (In App Workflows).