This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Around 7:45pm Pacific Time, our engineering team identified errors when accessing Smartsheet or making changes to assets. We made changes to our infrastructure and and observed gradual recovery. Smartsheet fully recovered at 9:33pm Pacific Time.
Posted Jan 17, 2026 - 21:41 PST
Resolved
Core Application functionality has been fully restored and is operating normally. The incident is now resolved.
Posted Jan 17, 2026 - 21:36 PST
Monitoring
We are observing stability being restored for the Core Application. We are continuing to monitor it closely to confirm full service stability.
Posted Jan 17, 2026 - 21:26 PST
Investigating
We are investigating errors when accessing and loading the Smartsheet application. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.
Posted Jan 17, 2026 - 21:09 PST
This incident affected: Core Application (Smartsheet Login, Single Sign On ( Company Credentials ), Sheets, Reports, Dashboards).